New Version

1 answer

I have noticed with all the beta versions of SambaPos that I have to uninstall the previous version before using the new version.

lemmings's picture
asked on Jun 23, 2013 and it has 3747 views.
See the Best Answer
We have already answers to
1029 questions
E-Posta Facebook Twitter RSS Skype
Telefon (212) 252 0634